Page MenuHomePhabricator

Fails to build for corstone500 with clang
Closed, InvalidPublic

Description

If I build TF-A 2.4 with clang 12 for corstone500 (aarch32, cortex-A5) it fails in the assembler:

a5ds/debug/bl1/bl1_entrypoint.o] Error 1
:2: error: use of SP in the list is deprecated
 ldm r1!, {sp, lr}
 ^
bl1/aarch32/bl1_exceptions.S:156:2: note: while in macro instantiation
 monitor_exit
 ^
<instantiation>:40:2: error: use of SP in the list is deprecated
 ldm r1!, {r2, sp, lr}
 ^
bl1/aarch32/bl1_exceptions.S:156:2: note: while in macro instantiation
 monitor_exit
 ^
<instantiation>:44:2: error: use of SP in the list is deprecated
 ldm r1!, {r2, sp, lr}
 ^
bl1/aarch32/bl1_exceptions.S:156:2: note: while in macro instantiation
 monitor_exit
 ^
<instantiation>:48:2: error: use of SP in the list is deprecated
 ldm r1!, {r2, sp, lr}
 ^
bl1/aarch32/bl1_exceptions.S:156:2: note: while in macro instantiation
 monitor_exit
 ^
<instantiation>:52:2: error: use of SP in the list is deprecated
 ldm r1!, {r2, sp, lr}
 ^
bl1/aarch32/bl1_exceptions.S:156:2: note: while in macro instantiation
 monitor_exit
 ^
<instantiation>:56:2: error: use of SP in the list is deprecated
 ldm r1!, {r2, sp, lr}
 ^
bl1/aarch32/bl1_exceptions.S:156:2: note: while in macro instantiation
 monitor_exit
 ^

Event Timeline

rossburton closed this task as Invalid.Tue, Jun 15, 11:22 AM

Duplicate of T873.