Build failed on AN524/musca_b1 platform when -DMBEDTLS_DEBUG=ON
Closed, WontfixPublic

Description

It looks like code region for crypto is too small for debug version mbedtls.
check below logs:

Error: L6221E: Load region LR_CODE with Load range [0x100c0400,0x1010ae84) overlaps with Load region LR_VENEER with Load range [0x100ff900,0x100ffb40).
Error: L6221E: Execution region TFM_SP_CRYPTO with Execution range [0x100dbca0,0x10104ff8) overlaps with Execution region ER_CODE_CMSE_VENEER with Execution range [0x100ff900,0x100ffb40).
Finished: 0 information, 34 warning and 2 error messages.
app/secure_fw/CMakeFiles/tfm_s_1.dir/build.make:142: recipe for target 'app/secure_fw/tfm_s_1.axf' failed
make[2]: * [app/secure_fw/tfm_s_1.axf] Error 1
CMakeFiles/Makefile2:399: recipe for target 'app/secure_fw/CMakeFiles/tfm_s_1.dir/all' failed
make[1]:
* [app/secure_fw/CMakeFiles/tfm_s_1.dir/all] Error 2
Makefile:129: recipe for target 'all' failed
make: *** [all] Error 2

qixiang created this task.Jul 2 2019, 8:45 AM

Hi Kevin,
Can you help to take a look?
-Ken

HI @qixiang , the option to build with the debug version of Mbed Crypto or Mbed TLS is presented in our documentation just for the sake of completeness, but it's not something that we actively guarantee (i.e. we can't guarantee that the debug version of the mbedcrypto/mbedtls library will fit on all our platforms, due to different requirements in size). The option should be left as default and overriden only on those platforms that can afford it, and only on designed debug sessions. In my experience so far with the Crypto service, there is no need to debug the mbedcrypto/mbedtls libraries, as that would be out of scope for a TF-M deployment. Please let me know if you have questions or doubts about this.

Thanks for your feedback.

If the AN524 and Musca_b1 have enough memory, we should support all the debug options since the AN524 and Musca platform are the reference platform. Partner maybe use it do anything.

Hi @qixiang , the problem is right about memory, I don't think we have enough space to support debug options for crypto on both platforms.
If you agree, can we close it as "won't fix". Thanks.

kevin-peng-hao closed this task as Wontfix.Oct 23 2019, 6:29 AM