Broken ConfigRegression runtime error on Musca_A platform
Closed, ResolvedPublic

Description

The ConfigRegression build on Musca_A platform interrupts after boot and initialising the secure image. It doesn't perform the regression tests anymore.

The last working patch is: https://review.trustedfirmware.org/c/trusted-firmware-m/+/1559

The next patch (https://review.trustedfirmware.org/c/trusted-firmware-m/+/1560) doesn't compile because of an incorrect return type. The patch that fixes the incorrect return type is https://review.trustedfirmware.org/c/trusted-firmware-m/+/1602, but the ConfigRegression build is broken.

TudorCretu triaged this task as High priority.
TudorCretu closed this task as Resolved.

Add the initialisation of the MPC interrupt driver on Musca_A platform.
Perform manual tests of ConfigRegression and ConfigRegressionIPC on Musca_A2 platform.
The patch passes internal CI tests.