Docuent build fails if PDF generation tools are present
Closed, ResolvedPublic

Description

Currently documentation build fails if PDF generation tools are available in the build environment.

The problem is caused by CMAKE_MAKE_PROGRAM not being set when the document creation targets are defined. As a result CMake generates “empty” targets which do not execute the final step of PDF generation.
The problem was triggered by project re-organization (moving secure fw build out of app territory) . The issue could have been avoided if the document generation cmake files did not missed checking the CMAKE_MAKE_PROGRAM which is an input of them.

gyuri-szing triaged this task as Low priority.
gyuri-szing closed this task as Resolved.Wed, Sep 4, 1:42 PM

Fix merged.