USART driver implementations for platforms included in TF-M
Closed, ResolvedPublic

Description

As already mentioned all USART drivers implemented for various platforms included in TF-M are not compliant with CMSIS USART Driver specification. They implement blocking send/receive and no power on/off.

Drivers should be rewritten and should pass the CMSIS Driver Validation.

RobertRostohar triaged this task as High priority.
davidwang claimed this task.
davidwang added a subscriber: mingyangSun.
mingyangSun added a comment.EditedDec 3 2019, 2:07 AM

Hi, @RobertRostohar
If we remove the "FILE _stdout" declaration from uart_stdout.c as mentioned(It prevents Clib mutex initialization), ARMCLANG image will not output anything anymore.
As the example shown in the link:
http://infocenter.arm.com/help/index.jsp?topic=/com.arm.doc.100073_0613_00_en/chr1358938930615.html
"FILE _stdout" is needed for retargeting.
We do not have the same environment(CMSIS-Pack with MDK environment) to reproduce the output in your environment.
Wonder if you knew the root cause of why "FILE __stdout" prevents Clib mutex initialization?

It seems that we can reimplement low level I/O functions such as _sys_write() and _ttywrch(). In that way, we do not need to declare "FILE __stdio".

mingyangSun closed this task as Resolved.Tue, Dec 31, 2:05 AM