Page MenuHomePhabricator

TFM regressions tests seem to hang on QEMU for mps2_an521
Closed, ResolvedPublic

Description

Zephyr CI runs the TF-M regressions tests as part of the TF-M integrations. We notice that the regression tests are hanging when running on QEMU for mps2_an521.
It seems the same issue is present upstream TF-M.

To reproduce:
Follow the instructions in the comment that is present here: https://github.com/zephyrproject-rtos/zephyr/pull/36954. Reproduce this with upstream TFM.
We have tested both qemu 5.1.0 and 6.0.0 and hanging is observed with both qemu versions.

Hanging occurs on NS regression tests (PS suites). The link above contains a log of the error.

Event Timeline

ioannisg triaged this task as High priority.Jul 16 2021, 1:07 PM
ioannisg created this task.
ioannisg updated the task description. (Show Details)Jul 16 2021, 1:09 PM
ioannisg added a subscriber: microbuilder.
ioannisg updated the task description. (Show Details)Jul 16 2021, 1:14 PM

Hi @ioannisg , this is due to this bug in QEMU:

https://patchew.org/QEMU/20210520130905.2049-1-peter.maydell@linaro.org/

This will be fixed in the next release which is targeted by mid/end of August.

Thanks Antonio for the information.
Since this is not a TF-M issue, suggest closing it.

Probably better to reduce the priority of the ticket but keep it open just to make sure we are reminded to verify it again once the next release of qemu is available.

OK, could you take this issue, @adeaarm ?

adeaarm claimed this task.Jul 20 2021, 9:33 AM
adeaarm lowered the priority of this task from High to Low.
adeaarm added a subscriber: kevin-peng-hao.
adeaarm added a project: Restricted Project.Aug 13 2021, 10:09 AM

Verified by building qemu 6.1.0 from source as it's been released on 24/08. Regression for AN521 passes without problem on this version. Closing this ticket with a recommendation to re-enable Open CI test cases based on Qemu after upgrading the Qemu version available in Open CI to 6.1.0.

adeaarm closed this task as Resolved.Aug 31 2021, 11:56 AM