At present veneers generated for uniform secure service signatures are each pre- and postfixed individually in the corresponding header file: interface/include/tfm_veneers.h
Hide this "transport layer" naming convention by providing a MACRO that takes the secure service function name and substitutes the generated veneer name. This MACRO could then be used in the header file for individual function signatures as well as for abstraction layer wrappers corresponding to secure service functions, and would hide TF-M-internal naming convention from service owners and eliminate some dependencies.
Wrappers would invoke the macro with their respective secure service function names, which would in turn be replaced compile-time with the appropriate veneer name.
A proposed definition in line with Uniform Secure Service Signature naming would be
#define TFM_VENEER_NAME(secure_function_name) tfm_##secure_function_name##_veneer
This macro would eliminate confusion and inconveniences with pre- and postfixes needed when invoking uniform signature veneers.